Please don't use short variable names

When learning to code, one of the most confusing things was using short variable names in documentation and other people's code.

Things like $k and $v instead of $key and $value within loops, $i instead of $index, or $e when working with Exceptions.

I've also seen slightly better names, such as $idx for index or $ctx for context.

But what does this achieve?

Why not write the full variable name and clarify what it refers to?

It would be easier to read and understand for anyone reading the code, including Junior Developers and people new to your team or application.

There are no limitations - at least in the languages I use - to force this, such as a maximum number of characters in a file, so why not write the full variable name?

The only reason I can think of is to save time by pressing fewer keys, but code is read more than written, so it should be optimised for readability.

Your tests and CI pipeline don't have a preference.

The people reading the code will.

- Oliver

Was this interesting?

Sign up here and get more like this delivered straight to your inbox every day.

About me

Picture of Oliver

I'm an Acquia-certified Drupal Triple Expert with 17 years of experience, an open-source software maintainer and Drupal core contributor, public speaker, live streamer, and host of the Beyond Blocks podcast.